Répondu

Problème Airplay depuis IOS14 sur Sonos


Bonjour. 
J’utilise habituellement la fonction AirPlay de mon iPhone XR ou de mon iPad Pro dernière génération, afin d’écouter Deezer sur ma Sonos Playbase, sans soucis depuis des mois. Or, depuis la mise à jour ios14 de mes deux appareils, lorsque j’utilise Deezer en AirPlay, j’ai de très nombreuses saccades de son, voire de franches coupures.

Je n’ai pas de problème, en revanche, avec les mêmes appareils, lorsque j’utilise l’application Apple Music ou YouTube en AirPlay. Le problème semble donc bien venir de Deezer. 
Quelqu’un rencontre-t-il le même problème ?

Deezer prévoit-il une mise à jour corrigeant ce soucis ?

Je vous remercie. 
Bonne journée. 
François

icon

Meilleure réponse par fptdm17 8 October 2020, 09:10

Afficher l'original

14 commentaires

Niveau d'utilisateur 7
Badge +2

Bonjour @fptdm17, nous n’avons pas encore constaté ce genre de problème de notre côté, ce qui ne veut pas dire qu’il n’y en a pas. Peux-tu nous donner ta version de l'application Deezer, le modèle de ton enceinte Sonos et la version du logiciel Sonos ?

Bien à toi

Bonjour. 

Merci pour ton message. Je précise que j'ai effectué différentes  manipulations (vider les données, désinstaller, éteindre, rallumer, réinstaller), elles n'ont rien changé au problème.

 

Sur mon iPhone XR comme sur mon iPad Pro 2020, l'application Deezer est à jour avec la version 8.23.0

iOS est également à jour avec la version 14.0.1

 

Mon système Sonos est composé d'une Playbase couplée avec deux Play:1 (configurées en home cinéma). Mon Sonos OS est S1 (car j'ai une autre enceinte Play:5 non compatible avec S2) 11.2.3

 

Merci pour ton aide !

Niveau d'utilisateur 7
Badge +2

Bonjour @fptdm17, merci pour ces précisions. Je vois que Sonos vient de sortir une nouvelle mise à jour  (11.2.4) pour S1, pourras-tu nous dire si le problème se pose encore une fois que tu seras à jour ?

Bonjour. 
Sur l’App Store, la dernière version de Sonos S1, qui date bien du 24/09/2020, est la 11.2.3 (et non la 11.2.4). Comme s'il y avait une erreur dans la note de version sur le site Sonos…

Merci. 

Bonjour.

J'ai fait les essais suivants :

  • Diffusion de Deezer via Airplay avec un iPhone 7 sous iOS 14 : toujours des saccades du son. 
  • Même essai avec des musiques téléchargées sur l'app Deezer : toujours des saccades du son. 
  • Essai en AirPlay avec un vieil iMac resté sous OS 13.6 : PAS de saccades du son.

 

J'ai ensuite mis à jour mon système Sonos vers la nouvelle version Sonos S2 (en supprimant mon enceinte non comptable). Résultat :

  • sous Sonos S2, en AirPlay avec iPhone XR et iPad Pro 2020 sous iOS 14 : TOUJOURS des saccades. 

 

Dans tous les cas, les essais avec les apps Apple Music ou YouTube en AirPlay restent concluants, sans saccade du son. 

Je ne vois pas d'autres explications qu'un problème apparu dans l'application Deezer au moment du passage sous iOS 14. J'utilise en permanence la fonctionnalité AirPlay avec Deezer, l'intégration dans l'app Sonos étant très mauvaise. Je vous remercie de ce que vous pourrez faire. 

 

Bonne journée. 

 

François 

Niveau d'utilisateur 7
Badge +2

Bonjour @fptdm17, merci pour tous ces détails, que je vais pouvoir transmettre à l’équipe iOS. Quelle est désormais ta version de l’application Sonos S2 ?

Bonsoir.

 

Ma Version Sonos S2 est la 12.1. 

 

J'ai fait des tests supplémentaires.

Résultats négatifs (toujours des saccades du son) : 

En supprimant le wifi 5 pour ne laisser que le 2.4

En supprimant certaines bandes wifi (g,n...)

En coupant le Bluetooth

 

Résultats positifs (pas de saccade du son) :

En utilisant un vieil iPad bloqué en iOS 12.4.8 avec Deezer 8.23.0

En se connectant au Airplay de l'Apple TV au lieu de se connecter directement à ma Playbase Sonos.

En utilisant un MacBook Air 2019 à jour sur macOS 10.15.7 avec l'app desktop Deezer à jour 

 

Conclusion : il y a un problème d'Airplay entre Deezer (à jour en 8.23.0) sur iPhone et iPad (à jour sous iOS 14) et la Sonos Playbase (à jour en S2 12.1 comme en version S1) , problème qu'on ne retrouve pas sous d'anciens iOS ou sur MacBook, et qu'on ne retrouve pas avec d'autres applications comme Apple Music ou YouTube. 

 

Merci de ton aide !

Niveau d'utilisateur 7
Badge +2

Bonjour @fptdm17, nous avons testé de notre côté, et nous n’arrivons pas à reproduire le problème. Il se pourrait que cela soit dû à ta configuration réseau. Pourrais-tu tester sur une seule enceinte à la fois, ainsi qu’en filaire plutôt qu WiFi si cela t’est possible ?

Bonjour. 
Effectivement, lorsque j'essaie la Sonos Playbase en déconnectant les Play:1 (en les débranchant électriquement), il n'y a plus de micro-coupures avec Deezer sur iOS via AirPlay. 

Même chose en branchant la Playbase en ethernet, même en laissant cette fois les Play:1 activées : il n'y a plus de micro-coupures. 
En revanche, dès que je remets tout cela en wifi, Playbase + 2 Play:1 en surround, il y a des saccades. 
Je répète que cela n'arrive qu'avec Deezer sous iOS 14 en AirPlay, pas avec d'autres applis comme Apple Music ou YouTube, pas avec un Mac, et pas avec d'anciennes version d'iOS.

J'ai aussi tenté des changements de canal wifi, sur le routeur comme sur la Playbase, rien n'y fait. 
Pour l'instant, je n'ai pas tenté le reset usine…

Merci. 

Niveau d'utilisateur 7
Badge +2

Bonjour @fptdm17, oui j’ai bien vu que tu avais testé avec d’autres services. Après en avoir discuté avec l’équipe iOS, l’explication pourrait être que Deezer n’utilise pas la même couche audio d’Apple que ces autres services. Quoi qu’il en soit, s’il t’est possible d’enregistrer ces sons saccadés, envoie-les nous de manière à ce que nous puissions les analyser de notre côté et voir si cela nous évoque quelque chose. 

Encore une fois, merci pour ta persévérance dans tes tests, la manière dont tu expliques tout cela est extrêmement claire :slight_smile:

Bonjour et merci encore de te pencher sur la question, ainsi qu'à l'équipe iOS. 

Voici un enregistrement avec quelques micro-coupures : https://drive.google.com/file/d/13q8Z8vDBHZ7A6gjlA8LnAyZYD9HIbj23/view?usp=drivesdk

J'espère que tu pourras y accéder via ce lien. 

On entend les coupures (à peu près) à :

8"

16"

35"

55"

1'23"

 

J'apporte quand même une précision, qui est plutôt une bonne nouvelle pour moi : je viens de remplacer ma "vieille" Sonos Play:5 (sous Sonos S1, sans AirPlay) par une toute nouvelle Sonos One (sous Sonos S2, avec AirPlay). Elle est configurée dans une autre pièce que la Sonos Playbase et ses Play:1.

Résultat : lorsque je me connecte en AirPlay à la Sonos Playbase, il y a toujours des micro-coupures (comme en témoigne l'enregistrement). 

En revanche, lorsque je me connecte en AirPlay à la fois à la Playbase et à la nouvelle One, et bien il n'y a plus de saccades, même sur la Playbase !

Cela me permet de profiter à nouveau de la fonction AirPlay, qui est bien meilleure que l'application Sonos, qui intègre si mal Deezer. 

 

Il est vrai que tout cela est difficilement compréhensible...

Je reste à ta disposition pour tout test supplémentaire. 

 

Bonne soirée. 

 

François

Niveau d'utilisateur 7
Badge +2

Bonjour @fptdm17, je te confirme que nous avons bien pu télécharger et écouter ce que tu nous as envoyé, merci :slight_smile: Nous entendons bien les micro coupures. Nous n’avons pas d’explications pour le moment, en tout cas je suis content que tu aies maintenant une configuration qui te permette d’écouter Deezer sans problème. 

Bonne soirée à toi également

 

Niveau d'utilisateur 4
Badge +1

Bonjour @fptdm17,

Comment sont connectées les 2 enceintes au réseau local ? En ethernet ? En Wi-Fi 2.4 GHz ? En Wi-Fi 5 GHz ?

Si elles ne sont pas connectées de la même manière, je te conseillerais de connecter la Playbase comme la One, et de préférence en filaire.

D’après ton message précédent, le problème se produit surtout lorsque la Playbase et les 2 Play:1 sont en Wi-Fi et que tu ne joues que sur la Playbase. Le fait que ces 3 enceintes soient groupées dans la même pièce doit poser problème j’imagine, elles doivent essayer de synchroniser la lecture même si elles ne jouent pas. Le fait que tu joues aussi sur la One doit “casser” le groupe.

Comme tu le dis, le problème est apparu avec iOS 14, donc on peut espérer qu’il soit remonté à Apple et qu’ils le corrigent dans une mise à jour. Le fait que le problème ne soit pas présent avec d’autres application est certainement lié au module audio utilisé, Apple propose d’accéder à l’audio à différents niveaux et cela peut occasionner des différences de comportement.

Bonjour @GuillaumeDZ 

Merci beaucoup pour ton message. 
Mes enceintes sont connectées en wifi 2.4. Je crois que Sonos ne supporte pas le 5 GHz. Et mon installation ne me permet pas une connexion en ethernet (sauf exceptionnellement pour dépannage). 
On va donc espérer une mise à jour d’Apple. Pour l'instant, ça passe en utilisant AirPlay sur les deux enceintes à la fois...

Très bonne journée. 😊
François 

Commenter