Répondu

Coupures fréquentes et pendant plusieurs secondes avec Squeezebox



Afficher le premier message

94 commentaires

Bonjour,

Quelques nouvelles de mon essai Spotify. Cela fonctionne...tant que LMS est activé, donc PC allumé. Ce qui n'arrange pas nos affaires.
Pour le moment, le plugin n'est pas indépendant de LMS mais le développeur y travaille.

Bonjour.
J'ai noté quelques améliorations depuis quelques jours, même si le problème n'est pas encore résolu (investigations toujours en cours). Vous pouvez essayer de modifier la valeur de la taille du tampon depuis le site mysqueezebox.com via le menu "Platines", puis dans l'onglet "Réseau" mettre la valeur "Taille du tampon radio" à 30.
Bonjour,

En ce qui me concerne j'avais déjà augmenté la valeur à 10 mais j'avais lu que certains avaient procédé à ce réglage sur 30 sans réelle amélioration. Je vais tenter 30. On ne sait jamais !
Bonjour,

Même pb de mon côté avec Deezer via Orange !

J'ai deux accès internet, l'un via Orange et l'autre via BouygTel.
Via Orange : pb de lenteur avec la squeezebox
Via BouygTel : Aucun pb.
Tests fait donc avec le même équipement Squeezebox Duet.
Le problème est donc bien via Orange pour contacter Deezer.

Serait-ce un problème de peering ? Je ne crois pas trop car Deezer à partir d'un PC ou d'un mobile connecté à la box opérateur ne pose aucun pb, et là, il y a une petite différence :
  • A partir d'une squeezebox, la connexion s'effectue sur un serveur particulier sur un port tcp/9000, un squeezebox serveur en sorte. (c'est visible en activant le SSH sur une squeezebox duet - Paramètres>Avancé>Connexion à distance - pour s'y connecter ensuite en ssh et en tapant la commande "netstat -na" vous aurez toutes les connexions effectuées).
  • A partir d'une appli sur Smartphone Android/Apple ou de l'appli PC Deezer ou via site web, la connexion est sans doute faite via du https=port tcp/443. C'est ce que je vois depuis un PC avec accès depuis l'appli ou site web Deezer.
C'est donc bien le cas de figure "écoute Deezer à partir d'une squeezebox via Orange". Une autre personne a indiqué que ça fonctionnait via SFR.
Pour moi, ce n'est pas les squeezebox qui sont en cause ou même Deezer, mais c'est côté Orange et le lien internet qu'ils font pour atteindre Deezer, voir même le flux spécifique tcp/9000 effectués par les squeezebox pour atteindre les serveurs de Deezer... genre une petite CoS un peu trop restrictive sur ce flux tcp/9000 qui limiterait la bande passante et qui provoquerait les lenteurs de bufferisation sur les squeezebox, ça ne me paraitrait pas impossible de la part d'Orange pour "préserver" leur réseau wan et prioriser d'autres flux tout aussi gourmand comme la TV ou optimiser la VOIP qu'ils veulent développer de plus en plus et sur lesquels ils préfèrent investir car bien plus rentable pour eux.

C'est quand même un peu balot vu que l'offre Deezer dont je profite est comprise dans l'abonnement de mon accès internet fibre Orange, ou bien, je n'ai pas tout compris à la logique commerciale d'Orange...
Mais si ils continuent, je vais vite comprendre qu'ailleurs ça fonctionne mais j'aurai mon abo Deezer à payer à part.
Petit ajout à mon précédent post :

J'ai fait d'autres tests en incluant sur mon réseau un NAS D-Link DNS-345 avec l'add-on SqueezeCenter et en paramétrant la buffurisation au max à 30 secondes et d'autres paramètres pour maximiser les perf du squeezecenter.
C'est donc le SqueezeCenter qui fait la connexion au serveur Deezer et qui fait le buffer,...
puis mon Squeezebox Duet se connecte au SqueezeCenter du NAS pour diffuser la musique (je vois bien le flux sur la Sqzbx duet en procédant de la même manière que défini ds mon précédent post)...
et là, beaucoup moins de problème de coupure à cause du phénomène de bufferisation très lente.

Ceci dit, je n'arrive pas clairement à identifier le flux utilisé par le SqueezeCenter du NAS pour se connecter aux serveurs de Deezer : tpc/9000 ou TCP/443(https) ou autre.
...ou bien, ça a fonctionner par ce que j'ai fait ces tests à une heure tardive. Je les referai à un autre horaire pour en avoir le coeur net.


... Et ça fait plaisir de ne pas se sentir seul, confronté à ce problème Orange/Deezer/Squeezebox.
Re-ajout:
Au niveau connexion par contre, je vois bien la connexion du Sqzbx duet vers l'ip du NAS et le port correspondant au SqzCenter. Donc, c'est bien le SqzCenter qui se connecte à Deezer et plus la Sqzbx Duet. Mais grande interrogation sur le type de cette connexion SqzCenterServeurs Deezer.
bonjour,
Dégouté le problème est revenu sur mon système:
Touch / duet / Radio
NAS synology avec squeezebox media server
Deezer

J'ai testé de connecter mon NAS à un VPN à Paris mais même problème
Bonjour,
Le problème persiste !
Cordialement,
Pascal

Bonjour,

Quelques nouvelles de mon essai Spotify. Cela fonctionne...tant que LMS est activé, donc PC allumé. Ce qui n'arrange pas nos affaires.
Pour le moment, le plugin n'est pas indépendant de LMS mais le développeur y travaille.
Bonjour.
J'ai noté quelques améliorations depuis quelques jours, même si le problème n'est pas encore résolu (investigations toujours en cours). Vous pouvez essayer de modifier la valeur de la taille du tampon depuis le site mysqueezebox.com via le menu "Platines", puis dans l'onglet "Réseau" mettre la valeur "Taille du tampon radio" à 30.

Bonjour,

Avons nous des nouvelles sur ce sujet.
Car maintenant même avec LMS il y a le problème de bufferisation.....Moins souvent qu'avec SBT mais quand même.

merci de vos infos .
Bonjour à tous,

Je constate une amélioration cette semaine que ce soit en journée ou en soirée. Pas de mises en tampon intempestives à l'écoute d'une playlist sur la Squeezebox radio.
L'avez-vous remarqué de votre côté?

Merci d'avance!
Bonjour
Je viens de réessayer avec squeezebox duet et cela fonctionne de nouveau, après 2 mois de mises en buffer répétées... Je croise les doigts 😃
Bonjour
Je viens de réessayer avec squeezebox duet et cela fonctionne de nouveau, après 2 mois de mises en buffer répétées... Je croise les doigts :D


Oh ben finalement ça ne fonctionne plus... Heureusement que sur ma chaine j'ai un dongle bluetooth ! Adieu squeezebox sans LMS ?
Bonjour,

Chez moi aussi : coupures à nouveau dans l'après-midi...
J'ai redémarré la Squeezebox radio et ça a refonctionné.

Continuons à nous tenir au courant et...croisons les doigts!
Bonjour,

Chez moi aussi : coupures à nouveau dans l'après-midi...
J'ai redémarré la Squeezebox radio et ça a refonctionné.

Continuons à nous tenir au courant et...croisons les doigts!


Depuis 2 semaines le même problème à peu près 50% du temps. Hier soir cela fonctionnait parfaitement et vers midi pas du tout. J'ai l'impression que cela vient d'un comportement particulier des serveurs cache de leur CDN.
Autre impression bizarre : cela fonctionne à travers le LMS sur mon PC, puis quand j'éteins ce dernier cela continue à marcher. Normalement cela devrait basculer sur mysqueezebox.com mais c'est comme si le boîtier avait toujours des "droits acquis" récupérés lors de la connexion au PC.
Je pense à un cookie ou une signature d'URL qui seraient bien validés par le serveur en face mais je n'en suis pas certain...
Ce qui est probable est que la SB connectée via sqB.com ne doit pas toujours avoir un cookie correct (sans doute un procédé de validation de signature ou de cookie se trouve impliqué dans le procédé), ou bien le user agent est filtré par le serveur, voire certains serveurs si nous avons un CDN avec des caches configurés de manière hétérogène.
Si cela se trouve, c'est un genre de bug plus qu'une volonté de filtrer les clients en fonction de leur matos.
Bon, je travaille chez orange mais malheureusement ce CDN est plus probablement sur la global platform d'akamai (pas certain mais bon...). Si cela avait été sur le CDN orange interne (serveurs dans le réseau opérateur sous licence akamai) j'aurais pu en parler à certains contacts qui ont eux-mêmes des contacts opérationnels pour débugger le truc.
Mais là je ne sais pas qui contacter.
Au final j'utilise pour ma chaine un WTX 500 bluetooth aptx et un chromecast audio pour youtube et deezer. C'est vraiment XXX de devoir laisser de côté la duet...
Bonjour,

J'ai le même type de problème, squeezebox Boom sur LMS de mon Synology, abonnement SFR Red par le cable, abonnement Deezer par Orange. Cela tend à aller dans le sens de Tommy22. J'essaie de régler le buffer à 30 secondes pour voir si cela améliore les choses.

Est ce que quelqu'un a signalé le problème à Deezer ?

Bon, je travaille chez orange mais malheureusement ce CDN est plus probablement sur la global platform d'akamai (pas certain mais bon...). Si cela avait été sur le CDN orange interne (serveurs dans le réseau opérateur sous licence akamai) j'aurais pu en parler à certains contacts qui ont eux-mêmes des contacts opérationnels pour débugger le truc.
Mais là je ne sais pas qui contacter.
Au final j'utilise pour ma chaine un WTX 500 bluetooth aptx et un chromecast audio pour youtube et deezer. C'est vraiment XXX de devoir laisser de côté la duet...
Salut tu es chez SFR et cela ne marche pas ???????
Merdoume je pensais que c'était Orange qui posait problème !

Bon bein Deezer a une part de responsabilité alors !
Bonjour à tous,

Mon diagnostic progresse. Je suis tombé sur un article connexe pour une Sonos qui m'a mis la puce à l'oreille. https://fr.community.sonos.com/amazon-alexa-et-sonos-229107/coupures-deezer-sur-sonos-si-lance-depuis-alexa-6768544
Depuis j'ai testé avec ma squeezebox en Ethernet : OK !
J'ai vérifié le Wifi sur la box en 2,4 Ghz, elle était sur un canal très encombré (le 6). Après migration de la box sur le canal 1 cela allait mieux mais encore des coupures.
Je viens de faire le test derrière un switch raccordé en Wifi 5GHz et la squeezebox raccordée en ethernet à ce dernier, pas de problème.

Pour tenter de mettre deezer en dehors de cause j'ai mis le serveur en mode "verbose" pour l'application Deezer. C'est vraiment bavard, je vois bien passer les symptomes du rebuffering passer dans les logs, de nombreux caches de deezer sont concernés. Donc cela ne viendrait pas d'un cache en particulier.

Ce qu'il me reste à faire :
  • Tester en wifi sans sécurité WPA pour voir si cela passe mieux
  • Tester en upgradant en Smart Radio (on ne sait jamais).
Est ce que quelqu'un aurait un tuto pour débugger le wifi ? Et pour récupérer des logs wifi pertinents sur la SqueezeBox ?

Merci,
Update du jour
J'ai effectué le test derrière mon switch connecté en wifi, j'ai eu de nouveaux épisodes de bufferisation.
Le côté positif est que du coup je vais pouvoir prendre une trace réseau de ce qui se passe.
Sinon par rapport à ce que j'ai lu dans le fil, la squeezebox et pilotée par le LMS dans le protocole SlimProto (dont le debug peut être activé côté serveur) et elle se connecte aux cdn de Deezer en HTTP directement sur le port 80 (j'ai une trace Wireshark).
Si quelqu'un est intéressé pour debugger avec moi je suis preneur.
Dernier update , je pense avoir trouvé le problème. Après de nombreux tests, j'ai pu voir que :
  • ce n'est pas dépendant de la sécurité du Wifi
  • ce n'est pas dépendant de la version SqueezeBox Radio vs Ue Smart Radio
  • Cela fonctionne en Ethernet.
  • cela se produit en wifi 2,4 Ghz ou en 5 Ghz (utilisé en tant que point d'accès Ethernet déporté).
J'en ai donc déduit que cela venait de la pile Wifi de mon routeur SFR (fournit avec l'offre RED THD sur Cable).
J'ai essayé sur ma ligne Orange en Smart Radio et cela fonctionne.
J’arrête donc là les investigations.
Bonsoir tt le monde,

Y a t'il eu des avancées ? Après avoir abandonné je constate que cela fonctionne très bien ce soir.
Je suis juste raccordé fibre depuis samedi. Mais je n'ai pas changé d'opérateur. C'est toujours Sosh donc orange.
C'est à rien n'y comprendre.

Commenter